BPEL assign, losing root element attributes

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

BPEL assign, losing root element attributes

sbuchan
Hi,

I have made a bpel process which calling a webservice in a
document/literal style which handle NewsMLG2 files.

I made a SA with a file transfert which take newsMLG2 files in a pooling
folder and as consumer a bpel process.

The bpel process receive a NewsMLG2 files and invoke a webservice to
process the NewsMLG2 File. For this invocation, I must assign the receive
variable to the webservice request message variable. The result is I lose
every attributes of the root element during the assignment !! All child
elements are well copy.

I don't understand why I have this behavior. If someone can help me it
will be welcome.

see below :
BPEL extract :
messageType="tns:NewsMLG2StoreProcessRequestMessage"/>

...
createInstance="yes" operation="storeToRepository"
portType="tns:NewsMLG2StoreProcess" variable="input" />






operation="storeNewsItem" portType="ns1:StoreNewsMLG2Interface"
inputVariable="newsMLStoreRequest" outputVariable="NewsMLStorePLResponse"
/>

WSDL extracts:
BPEL WS

element="news:newsItem" name="payload" />

1st WS

name="newsItem" element="ns1:newsItem" />



Messages show from the WebConsole.
Message from filetransfert component :

standardversion="2.1" standard="NewsML-G2"
guid="tag:afp.com,1998:TX-SGE:19980103T031928Z:ADA23:1" version="1">
...


Message from orchestra engine to the first web service :


...


regards,

Bertrand




-------------------- m2f --------------------

Read this forum topic online here:
http://petals.ebmwebsourcing.com/forum/viewtopic.php?p=356#356

-------------------- m2f --------------------

_______________________________________________
Users mailing list
[hidden email]
http://forum-list.petalslink.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: BPEL assign, losing root element attributes

sbuchan
Hi,

Indeed, It's a bug that we must corrected. You can post this bug on the bug tracker of petals-se-orchestra component.


Best regards,


Nicolas SALATGE




-------------------- m2f --------------------

Read this forum topic online here:
http://petals.ebmwebsourcing.com/forum/viewtopic.php?p=363#363

-------------------- m2f --------------------

_______________________________________________
Users mailing list
[hidden email]
http://forum-list.petalslink.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: BPEL assign, losing root element attributes

sbuchan
In reply to this post by sbuchan
Ok thanks,
I will do it if it is not already done.

Bertrand


:
Hi,

Indeed, It's a bug that we must corrected. You can post this bug on the
bug tracker of petals-se-orchestra component.


Best regards,


Nicolas SALATGE










-------------------- m2f --------------------

Read this forum topic online here:
http://petals.ebmwebsourcing.com/forum/viewtopic.php?p=364#364

-------------------- m2f --------------------

_______________________________________________
Users mailing list
[hidden email]
http://forum-list.petalslink.org/cgi-bin/mailman/listinfo/users