Petals web console: looking for 2.0.6 release

classic Classic list List threaded Threaded
12 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Petals web console: looking for 2.0.6 release

pguillot

Good morning everybody,

 

I have hit this bug: https://jira.petalslink.com/browse/PETALSWEBC-51.

 

Searching the forums and the web, I found it has been fixed in Petals web console 2.0.6.

But I only found "30 days links" to this release and I was not able to find a permanent download link to this version of the web console.

 

Would you be so kind to send me a link to download this 2.0.6 release?

 

I know there is Petals CLI, but what I need to provide to the admin guy, is a simple GUI for light admin operations, from time to time... For this purpose, the web console is just the perfect tool.

 

Thanks in advance.

Have a nice day.

Kind regards,

  Patrick

 

--

Patrick Guillot

e-Citiz BPM solution

 


_______________________________________________
Users mailing list
[hidden email]
http://forum-list.petalslink.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Petals web console: looking for 2.0.6 release

Christophe DENEUX
Administrator
Hi Patrick,

The Petals Web Console was abandoned with Petals 4 (Are you running a previous version of Petals ESB ?). The versions 2.0.6 and upper were never released. If needed, you can try the version 2.1-SNAPSHOT available here: http://maven.petalslink.com/public-snapshot/org/ow2/petals/petals-webconsole-ui/2.1-SNAPSHOT/

The issue you have mentioned requires a fix about MIME type declaration on your operating system. I don't remember that the Petals Web Console fix it itself, but according to the issue history, the problem is also fixed in the Petals Web console main line (version 2.1-SNAPSHOT).
Christophe DENEUX
Petals ESB Architect
Linagora
Twitter: @ChrisDENEUX
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Petals web console: looking for 2.0.6 release

pguillot
Hi Christophe,

Many thanks for your answers.

I gave it a try. A login/password is requested.

I tried "petals/petals": it did not worked.
I have found in "security.xml" that there is 3 user accounts: administrator,
operator and viewer.
I was not able to guess or found the corresponding password: I tried
"petals", "changeit", "admin", same as login - no luck.
I have used :
   java org.ow2.petals.tools.webconsole.services.security.util.CipherHelper
"petals"
to reset the passwords in "security.xml" and I restarted the web console.
Still no luck.

Any idea about the default logins/passwords?
Thanks in advance.


-----Message d'origine-----
De : [hidden email]
[mailto:[hidden email]] De la part de Christophe DENEUX
Envoyé : mercredi 23 septembre 2015 09:18
À : [hidden email]
Objet : Re: [Users] Petals web console: looking for 2.0.6 release

Hi Patrick,

The Petals Web Console was abandoned with Petals 4 (Are you running a
previous version of Petals ESB ?). The versions 2.0.6 and upper were never
released. If needed, you can try the version 2.1-SNAPSHOT available here:
http://maven.petalslink.com/public-snapshot/org/ow2/petals/petals-webconsole
-ui/2.1-SNAPSHOT/

The issue you have mentioned requires a fix about MIME type declaration on
your operating system. I don't remember that the Petals Web Console fix it
itself, but according to the issue history, the problem is also fixed in the
Petals Web console main line (version 2.1-SNAPSHOT).



-----
Christophe DENEUX
Petals ESB Architect
Linagora
Twitter: @ChrisDENEUX
--
View this message in context:
http://forum.petalslink.com/Petals-web-console-looking-for-2-0-6-release-tp4
025712p4025713.html
Sent from the Users (get help, provide help) mailing list archive at
Nabble.com.
_______________________________________________
Users mailing list
[hidden email]
http://forum-list.petalslink.org/cgi-bin/mailman/listinfo/users

_______________________________________________
Users mailing list
[hidden email]
http://forum-list.petalslink.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Petals web console: looking for 2.0.6 release

Christophe DENEUX
Administrator
This post was updated on .
I'm not be able to retrieve the user passwords. Have you try login as password: administrator/administrator, operator/operator, viewer/viewer ?

You can get more information here: https://doc.petalslink.com/display/petalswebconsolesnapshot/Webconsole+requirements, in chapter "Realm & JAAS Configuration"
Christophe DENEUX
Petals ESB Architect
Linagora
Twitter: @ChrisDENEUX
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Petals web console: looking for 2.0.6 release

pguillot
Christophe,

CD> password: administrator/administrator, operator/operator, viewer/viewer
?

Yes, I did try using passwords identical to logins.

Kind regards,
        Patrick

-----Message d'origine-----
De : [hidden email]
[mailto:[hidden email]] De la part de Christophe DENEUX
Envoyé : mercredi 23 septembre 2015 11:56
À : [hidden email]
Objet : Re: [Users] Petals web console: looking for 2.0.6 release

I'm not be able to retrieve the user password. Have you try login as
password: administrator/administrator, operator/operator, viewer/viewer ?

You can get more information here:
https://doc.petalslink.com/display/petalswebconsolesnapshot/Webconsole+requi
rements,
in chapter "Realm & JAAS Configuration"



-----
Christophe DENEUX
Petals ESB Architect
Linagora
Twitter: @ChrisDENEUX
--
View this message in context:
http://forum.petalslink.com/Petals-web-console-looking-for-2-0-6-release-tp4
025712p4025715.html
Sent from the Users (get help, provide help) mailing list archive at
Nabble.com.
_______________________________________________
Users mailing list
[hidden email]
http://forum-list.petalslink.org/cgi-bin/mailman/listinfo/users

_______________________________________________
Users mailing list
[hidden email]
http://forum-list.petalslink.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Petals web console: looking for 2.0.6 release

pguillot
Hi all,

Just a comment to let everyone know that this issue is unresolved.
We have not been able to reconfigure the logins/passwords, even with the help of the provided documentation.
Kind regards.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Petals web console: looking for 2.0.6 release

Victor Noël
Administrator
Hi, have you checked the logs for any errors that would explain why the default passwords do not work?
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Petals web console: looking for 2.0.6 release

pguillot
In reply to this post by pguillot
Hi Victor,

Since I don't know the default passwords, I didn't tried them. Instead, I tried to change the passwords, using this command:
 java org.ow2.petals.tools.webconsole.services.security.util.CipherHelper "petals"
It produced a hashed password, which I put in security.xml (located in petals-webconsole-ui-2.1-SNAPSHOT\WEB-INF\classes\security.xml):
<ns:EntityPrincipals xmlns:ns="xmlmap://org.ow2.petals.tools.webconsole.services.security.auth/unversioned" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="xmlmap://org.ow2.petals.tools.webconsole.services.security.auth/unversioned security.xsd ">
  <ns:EntityPrincipal name="administrator" password="70bc33a8dd0f5fca418ddd833b908e2ed990024b">
    <roles>administrator</roles>
  </ns:EntityPrincipal>
  <ns:EntityPrincipal name="operator" password="70bc33a8dd0f5fca418ddd833b908e2ed990024b">
    <roles>operator</roles>
  </ns:EntityPrincipal>
  <ns:EntityPrincipal name="viewer" password="70bc33a8dd0f5fca418ddd833b908e2ed990024b">
    <roles>viewer</roles>
  </ns:EntityPrincipal>
</ns:EntityPrincipals>

When I try to login using e.g. "administrator" / "petals", I get an exception stating that jaas.config file cannot be found:
 java.io.IOException: Impossible de trouver une configuration de connexion
com.sun.security.auth.login.ConfigFile.init(ConfigFile.java:250)
com.sun.security.auth.login.ConfigFile.<init>(ConfigFile.java:91)

"Impossible de trouver une configuration de connexion" => "unable to find a connection configuration"

Here my configuration:

jaas.config:
=======
WebconsoleJAAS {

   org.ow2.petals.tools.webconsole.services.security.auth.EntityJAASLoginModule required debug="true";

};
=======

webapps\petals-webconsole-ui-2.1-SNAPSHOT\WEB-INF\classes\security.xml:
=======
<?xml version="1.0" encoding="UTF-8"?>

<Context docBase="petals-webconsole-ui" path="/petals-webconsole-ui" reloadable="false" source="org.eclipse.jst.j2ee.server:petals-webconsole-ui">
        <Realm className="org.apache.catalina.realm.JAASRealm" appName="WebconsoleJAAS" userClassNames="org.ow2.petals.tools.webconsole.services.security.auth.EntityPrincipal" roleClassNames="org.ow2.petals.tools.webconsole.services.security.auth.EntityRolePrincipal"/>
</Context>
=======

catalina.bat (apache-tomcat-6.0.32):
=======
set AUTH_CONFIG=-Djava.security.auth.login.config="C:\xxxxxx\petals\apache-tomcat-6.0.32\conf\jaas.config"
SET JAVA_OPT=%JAVA_OPT%  %AUTH_CONFIG%
=======

Here is the command executed by catalina.bat:
start "Tomcat" "C:\_dev_\tmp\jdk1.6.0_24\bin\java"  -Djava.util.logging.config.file="
C:\xxxxxx\petals\apache-tomcat-6.0.32\conf\logging.properties" -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManage
r   -Djava.endorsed.dirs="C:\xxxxxx\petals\apache-tomcat-6.0.32\endorsed" -classpath "C:\xxxxxx\petals\apache-tomcat-6.0.32\
bin\bootstrap.jar" -Dcatalina.base="C:\xxxxxx\petals\apache-tomcat-6.0.32" -Dcatalina.home="C:\xxxxxx\petals\apache-tomcat-6
.0.32" -Djava.io.tmpdir="C:\xxxxxx\petals\apache-tomcat-6.0.32\temp" org.apache.catalina.startup.Bootstrap  start

Any idea?
Thanks in advance for any suggestion you may have.
Regards,
Patrick
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Petals web console: looking for 2.0.6 release

pguillot
The correct translation of the exception in english is:
"Unable to locate a login configuration"

Patrick
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Petals web console: looking for 2.0.6 release

Victor Noël
Administrator
In reply to this post by pguillot
I don't see the extra JVM parameter in the command line, are you sure it is passed to the process as desired?

That's why it can't find the file I guess…

You should simply set the JAVA_OPTS environment variable with your "-Djava.security.auth.login.config="C:\xxxxxx\petals\apache-tomcat-6.0.32\conf\jaas.config" in the shell and then execute the startup script from tomcat, it will take care of using it normally…
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Petals web console: looking for 2.0.6 release

pguillot
Hi Victor,

Damned! You are right.
I don't know what I had in my eyes... I would like to be a little mouse and hide in a hole.

Thanks to you, I found the error: it was a typo in the script update I made: the "S" was missing in "JAVA_OPTS". After fixing the typo, it works just fine.

Many thanks for you help.

Kind regards,
Patrick
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Petals web console: looking for 2.0.6 release

Victor Noël
Administrator
Good to known, these things are always treacherous :)
Loading...