Recommended JVM for PEtALS 3.0 ?

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

Recommended JVM for PEtALS 3.0 ?

sandre
Hello,

I'm currently running the PEtALS 3.0 ESB on a Sun JRE 1.6, and it seems to work.

But I'm wondering if Petals Link recommends a particular JVM, which one is used for tests?
IBM, Sun, openjdk, whatever?

Thx
Rolling Eyes




-------------------- m2f --------------------

Unsuscribe/Suscribe Petals forum notification
Read this forum topic online here:
http://petals.ebmwebsourcing.com/forum/viewtopic.php?p=30218#30218

-------------------- m2f --------------------

_______________________________________________
Users mailing list
[hidden email]
http://forum-list.petalslink.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Recommended JVM for PEtALS 3.0 ?

Mathieu Le Breton
Administrator
Hey Sebastien
Just to say, now we say Petals ESB 3.0
(not PEtALS 3.0 ESB :) ). Then you're free to do as you wish, but at
least you know it :)

Nice that it works on Sun JRE 1.6. It was mostly tested on 1.5 however,
so take care.
I would say it is the Sun JVM that is recommended, but prefer to have
confirmatio of that.

Cheers




Petals ESB, the open source ESB with federated architecture




-------------------- m2f --------------------

Unsuscribe/Suscribe Petals forum notification
Read this forum topic online here:
http://petals.ebmwebsourcing.com/forum/viewtopic.php?p=30263#30263

-------------------- m2f --------------------

_______________________________________________
Users mailing list
[hidden email]
http://forum-list.petalslink.org/cgi-bin/mailman/listinfo/users
Petals Link
Reply | Threaded
Open this post in threaded view
|

Re: Recommended JVM for PEtALS 3.0 ?

Charles.w
In reply to this post by sandre
This release has been tested only on Sun 1.5 VM without any optimisation activated (eg we did not tested it with the VM's -server option).




-------------------- m2f --------------------

Unsuscribe/Suscribe Petals forum notification
Read this forum topic online here:
http://petals.ebmwebsourcing.com/forum/viewtopic.php?p=30287#30287

-------------------- m2f --------------------

_______________________________________________
Users mailing list
[hidden email]
http://forum-list.petalslink.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Recommended JVM for PEtALS 3.0 ?

ccasadei-2
In reply to this post by sandre
Thank you for your answers, so I'm gonna use the Sun JVM 1.5 Smile

I know you guys worked hard on this release and I really appreciate having SCA and BPEL now supported Very Happy But I'm a little bit worried about the supported JVM. I mean the JDK 1.5 has reached its end of service date last month and some people are already working on the Java 1.7 specification...
http://java.sun.com/javase/downloads/index_jdk5.jsp
https://jdk7.dev.java.net/

Maybe the "Java 1.6 support" should be scheduled for the next release of PEtALS ESB? Or at least the compatibility should be tested, because in the near future some people may not want to work with JVM1.5 any more Shocked

Rolling Eyes




-------------------- m2f --------------------

Unsuscribe/Suscribe Petals forum notificationWBR:>
Read this forum topic online here:
http://petals.ebmwebsourcing.com/forum/viewtopic.php?p=30288#30288

-------------------- m2f --------------------

_______________________________________________
Users mailing list
[hidden email]
http://forum-list.petalslink.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Recommended JVM for PEtALS 3.0 ?

ccasadei-2
In reply to this post by sandre
Agree on the support of the JVM1.6...but Java SE 5 for business has not yet reached its EOL, according to this document : http://java.sun.com/products/archive/eol.policy.html

For Java 7, people are working on it since almost 3 years...and for years things like closures have been rejected...and last month, Sun finally changed its mind...some U turns like these may delay Java 7 even more...for now on, Java 7 is expected to see the light in june or july 2010...

Concerning the ESB itself, it works fine on Java 6...but some components don't...that's exactly why the ESB requirement is Java 5




-------------------- m2f --------------------

Unsuscribe/Suscribe Petals forum notificationWBR:>
Read this forum topic online here:
http://petals.ebmwebsourcing.com/forum/viewtopic.php?p=30289#30289

-------------------- m2f --------------------

_______________________________________________
Users mailing list
[hidden email]
http://forum-list.petalslink.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Recommended JVM for PEtALS 3.0 ? [Resolved]

flaborde
In reply to this post by sandre
Hi,

Developpement of new components has to be in 1.6 ?
I just switch to cdk-core version 5.02 and it seems to be build on jre 1.6.

seen in petals-cdk-api-2.0.2.jar :

Built-By: rnaudin
Build-Jdk: 1.6.0_16




-------------------- m2f --------------------

Subscribe/Unsubscribe emails notifications.

Response to this email will be posted on the Petals forum.
Please delete the existing text before responding :)

Read the topic online:
http://forum.petalslink.com/viewtopic.php?p=30523#30523

-------------------- m2f --------------------

_______________________________________________
Users mailing list
[hidden email]
http://forum-list.petalslink.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Recommended JVM for PEtALS 3.0 ? [Resolved]

rnaudin-4
Hi,

You'r right;
News




-------------------- m2f --------------------

Subscribe/Unsubscribe emails notifications.

Response to this email will be posted on the Petals forum.
Please delete the existing text before responding :)

Read the topic online:
http://forum.petalslink.com/viewtopic.php?p=30524#30524

-------------------- m2f --------------------

_______________________________________________
Users mailing list
[hidden email]
http://forum-list.petalslink.org/cgi-bin/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Recommended JVM for PEtALS 3.0 ? [Resolved]

flaborde
didn't see the news Rolling Eyes

thx !




-------------------- m2f --------------------

Subscribe/Unsubscribe emails notifications.

Response to this email will be posted on the Petals forum.
Please delete the existing text before responding :)

Read the topic online:
http://forum.petalslink.com/viewtopic.php?p=30526#30526

-------------------- m2f --------------------

_______________________________________________
Users mailing list
[hidden email]
http://forum-list.petalslink.org/cgi-bin/mailman/listinfo/users